chat

Resolved
Major outage
Started 16 days ago Lasted 15 minutes

Affected

Chat
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.